Requirements

Before installing Bacula-Web on your server, you must ensure that your system fullfill Bacula-Web requirements

  • ssh (root access) on the server
  • Apache Web server (at least version 2)
  • PHP version >= 5 with
    • Gettext support
    • GD library support (used for graphs)
    • TrueType support (optional)
    • PHP PDO and PHP support for MySQL, postgreSQL or SQLite (depend your Bacula setup)
    • Session support
  • Database connectivity to your Bacula director(s) database(s)
    • supported database MySQL, postgreSQL or SQLite